Ant video downloader for Firefox troubleshooting

For versions 2.4.7.22 and over.

FFMpeg is asking for authorization : 

During the installation process, Ant.com installs ffmpeg softare for you. You'll notice this package is verified by our team. 

To avoid the inconvenience of the popup message each time, uncheck the "Always ask me before opening this file" option. 

03.04.2014_-_asking_for_ffmpeg.png

A stream is missing : 

This may happen when you changed or deleted some files. On Youtube and other sites using MPEG-DASH format, our addon downloads both stream (audio and video). You need both of them to get full video.

Audio or video is missing : 

Probably missing one of the two streams. Our downloader downloads both audio and video stream for you. It needs both of them to prepare you the video.

I've downloaded my video, but I get no file in my folder :

Probably, the conversion has not finished. The conversion can take some time depending on the size of the video. Wait a bit longer before closing your browser. 

Have more questions? Submit a request

19 Comments

  • 0
    Avatar
    fahadna99

    Thanks

  • 0
    Avatar
    Ayush1967

    failed automatically install the media converter. Error Code is 9. Please try again later or configure the converter manually

  • 0
    Avatar
    Oksana

    Hi! Great news as we have fixed the mentioned problem. Ayush1967, you have to make sure that you have a new version 2.4.7.27 of AVD installed. It should have updated automatically. In case it has not, you can do it manually here: http://www.ant.com/video-downloader. If you have further problems, you can contact our support here: http://support.ant.com/tickets/new.

     

     

     

  • 0
    Avatar
    Shankar Veera

    I've downloaded my video which have two streaming file without work mode

  • 0
    Avatar
    Peter Milošič

    when I try to download some music from my Deezer account it would only download 5 or 6 songs and then just repeat downloading these.. what to do?

  • 0
    Avatar
    Ant V

    Hi Peter, 

    Can you please contact our support with all the details, like the exact links, your AVD version, browser version, Operating system. We need to test to identify a possible source fo the problem. 

    Ant V

  • 0
    Avatar
    Ant V

    Hi Shankar, 

    Do you have a converter installed? Try uninstalling and installing AVD again. Abour a converter you can read in more details here: http://support.ant.com/entries/30182610-How-to-install-Media-Converter-for-Youtube-Download.

    Hope you find this information useful. 

    Ant V

  • 0
    Avatar
    David Martin

    I have ADV 2.4.7.34 on Firefox 43.0.4, Recently a whole load of videos on Youtube have started appearing as WEBM files,

    I download these but only get the audio component. Anyone know what I'm doing wrong?

  • 0
    Avatar
    Ant V

    Hi David, 

    The source of the problem is most likely the missing converter. Install it manually following the instruction described here. Please, let me know if it worked out well. 

    Ant V

  • 0
    Avatar
    David Martin

    Your suggestion didn't help, this has been happening for about 6 months now. Even on a different computer.

    I have the converter installed but just to make sure I've re-installed it.

    Same issue is occuring.

    Tried this file: https://www.youtube.com/watch?v=Dmzlx7fNsDM (please excuse the movie selection, the wife wanted to see it)

    Downloaded at 480p & is a WEBM file.

    Once downloaded (only 1 stream) the file is called: The Life and Times of Grizzly Adams - YouTube.webm

    Seems it's not being converted as it's only downloading one stream.

    When opening this file today I only have the video stream, when downloading a lower quality I have only got the audio stream.

    This doesn't seem to be a problem with the converter but more the downloader.

    Have had to resort to using http://www.clipconverter.cc/ which is so slow to download from.

    I've only noticed this on a number of youtube videos that are webm, anything that's MP4 or FLV or other sites without WEBM don't have a problem.

    Please help as this is quite frustrating.

    Confirming specs:

    AVD 2.4.7.34

    Firefox 43.0.4 (although happened with the last 5 or so updates of Firefox & also happens with Waterfox).

    Windows 7 Professional

  • 0
    Avatar
    Ant V

    Hi David, 

    Thank you for detailed information, I have forwarded it to the Developers Team for further investigation. 

    Ant V

  • 0
    Avatar
    David Martin

    any updates?

  • 0
    Avatar
    Ant R

    This issue related to HTML5 videos converting problems in new Firefox versions, our developers team is currently working on the solution.

    Meanwhile, temporarily you can force your browser not to use .webm format in video streams by making a few simple changes in the Firefox configuration.

    You need to open "about:config" page in browser address bar, type "media.webm.enabled" in search field and change it to "false" by double-clicking.

    Problem should be fixed after restarting Firefox if you have Adobe Flash Player plugin installed, if no - you can find it at Adobe website: https://get.adobe.com/flashplayer/

    Please notice that this is only temporary solution until new version of AVD will be released.

    After upgrading AVD or in case of any problems with HTML5 online video playback you need to do everything in reverse order and enable .webm support in Firefox about:config page.

  • 0
    Avatar
    David Martin

    This works perfectly, thank you

  • 0
    Avatar
    Michael Brevoort

    I get great video but no audio, I am running it on windows 10. Win 7 did not have this problem. Does anyone else have this problem? and how con this be fixed?

  • 0
    Avatar
    Ant R

    Recently Ant.com had to change AVD downloads format due to compatibility problems with Opus audio stream in YouTube HTML5 player.

    For now videos will be saved in MP4, WEBM or MKV depending on YouTube player streams format supported by your browser and system configuration.

    In case of video or audio playback problems with new videos we recommend you to update your codecs with help of K-Lite Codec Pack: http://www.codecguide.com/download_kl.htm

    Either you can try to use third-party media player with Opus audio support. Ant.com recommends VLC player for this purpose: http://www.videolan.org/vlc/index.html

  • 0
    Avatar
    Melvin Schmoekenbachur

    I had AVD download from youtube, the audio is silent, I go to the troubleshooting link and am told:

    "Probably missing one of the two streams. Our downloader downloads both audio and video stream for you. It needs both of them to prepare you the video."

    Ummm... Yes - I know that the audio is not there.  And so what do I do about it?C',mon guys, ... you simply restate the problem - well, and add that AVD DOES downloads both. 
    And this leaves me, the user, with what helpful troubelshooting (note that word) information as to how to get the audio stream?Since I am not the programmer of AVD - I cannot go into the code and see why, after following instructions of how to use AVD, the audio file is not showing up!This reminds me a of Microsoft's "troubleshooting" efforts of which I am sure you are infinitely more capable.I have already spent quite a bit of time on this today that I did not want to.Think like a brain dead user when making troubleshooting hints please.

  • 0
    Avatar
    Cedric S

    I'm using AVD for Firefox on Mac and I am also getting a download without any audio track.

    I'm downloading from Vimeo, and only seems to be an issue with videos that are downloaded in chunks.

    Definitely seems to be an issue with the audio stream either not being captured at all, or not being combined with the recommended version of ffmpeg installed.

    Have opened the downloaded file in VLC and there is definitely no audio track present.

    Please advise on whether this is a bug that is being fixed? Is there a previous version available that will work successfully?

  • 0
    Avatar
    Ant R

    Cedric S

    Unfortunately AVD encountered an audio detection problem with videos from vimeo.com due to the recent changes in the way of streaming.

    Our developers are already working on solution and fix for this issue will be included to the nearest AVD release.

     
    Please foollow the instructions from this article: https://support.ant.com/hc/en-us/articles/115000513446-Firefox-51-Multi-Process Either contact to our support: https://support.ant.com/hc/en-us/requests/new

     

    Edited by Ant R
Please sign in to leave a comment.
Powered by Zendesk