I cannot playbck a video with AVD for Firefox Player. Why?

You may experience a playback problem with AVD for Firefox Player. If you see a message "A plugin needed to display this content", then you need either to install or enable Adobe Flash and Shockwave Player. 

You can install it from Adobe website here and here.

To enable the plugin, you should do the following:

1. Go to your browser menu, see a screenshot below;

rsz_1_1.jpg

2. Select 'Extensions';

rsz_1_2.jpg

3. Then select 'Plugins' > enable Adobe Flash and Shockwave Player.

rsz_1_3.jpg
Have more questions? Submit a request

5 Comments

  • 0
    Avatar
    Jim Findley

    i followed this but still am unable to play any videos on the movie player

  • 0
    Avatar
    Michael Olsen

    Same issue here.  Will not play as of a few days ago.

  • 0
    Avatar
    Michael Olsen

    There is no error given, attempting to play does literally nothing.  No error, no message, no indication that you are trying to play either when double clicking, or right clicking and selecting play.

    Followed your directions, and plugin is enabled, but your first link goes nowhere, as they no longer have that page at adobe. 

  • 0
    Avatar
    Elliot A Morgan

    I am with Michael Olsen: I do not get an error message, installed the software several times and still nothing. Spent three hours doing this!

    The right link to adobe flash is here: https://get.adobe.com/flashplayer/

    Still I get nothing. I see the list of videos, but the video does not load.

  • 0
    Avatar
    Ant R

    Unfortunately since Firefox 55 Mozilla made changes in Flash plugin support and some file formats, including MP4, are unsupported by AVD built-in player for now.

    Our developers already working on new AVD application with improved player to support future Firefox releases.

    You still can find all downloaded videos in the Ant Videos folder and play them with help of some third-party media player like VLC: http://www.videolan.org/vlc/index.html

    We keep trying to find any solution for this issue but at the moment the only way to fix AVD built-in Player is to downgrade Firefox to the version 54 or below.

    We are sorry for any inconvenience caused and hope for your understanding.

Please sign in to leave a comment.
Powered by Zendesk